Shorted my battery...

Post here for living area electrical.
Post Reply
Author
Message
Offline
New Member
New Member
Posts: 4
Joined: Sun May 07, 2017 9:40 pm
Travco Model: 1974 Travco 270

Shorted my battery...

Unread post by sakurathesteamqueen » Sun Jul 02, 2017 10:07 am

So yesterday i was up in Glen Rock PA(where my 1974 Travco 270 is stored until september, I live in Baltimore and only get one day a week to go and work on it) mainly focused on brake work but decided to try and fire up the engine for the first time since replacing valve cover gaskets. Went to hook up the battery in the driver side compartment( Ive been keeping it on a solar charger while not in use) and while tightening the positive lead the terminal got really hot and when i disconnected there was a decent spark. Went inside and could smell melted plastic but couldnt find anything burnt up. Looked in the battery compartment under the welcome mat my the door and the terminals were both touching ground. So I made sure the extra terminals were isolated/insulated from grounding or touching and hooked up battery again, went to turn it over and the brake light still comes on(brakes arent functional yet) but the starter didnt make any sound whatsoever. The battery was at 12.7 volts before shorting and dropped to 12.2 volts. Anyway I was wondering if any of you might know what the issue is now? Did i burn something up? Blow the main fuse? Also the second time I hooked up battery was to the terminals by the door not the driver compartment, not sure if that makes a difference cause they appear to go to the same place but figure I should mention it just in case. Just wanna get an idea of whats going on before I go up again to work on it. Thanks for any input you may have!

Offline
New Member
New Member
Posts: 4
Joined: Sun May 07, 2017 9:40 pm
Travco Model: 1974 Travco 270

Re: Shorted my battery...

Unread post by sakurathesteamqueen » Sat Jul 08, 2017 4:11 pm

So upon resuming work on my 270 today and finding out i need a hardwarekit for the rear passenger drum I started checking the starter and solenoid and eventually just before I was about to quit I notice a 3 prong plug disconnected from the tranny which Im assuming is for the neutral safety switch. Plugged it in and engine turned over but wasnt getting spark, so I fiddled with the 2 small wires on the ignition coil and tried again she fires right up! Im thrilled to have her running again, now I Just need to get the brakes finished(almost done, thank god), flush the radiator out/refill, and get situated with tires before I can bring her back to MD making her first self-propelled voyage since 1990! Then ill be able to revamp the interior without any deadlines.

Offline
Moderator
Moderator
Posts: 1045
Joined: Wed Nov 19, 2014 2:26 pm
Travco Model: 76 Mahal 2+2
Location: Arnoldsville GA
Contact:

Re: Shorted my battery...

Unread post by KB2CRK » Sat Jul 08, 2017 6:43 pm

That is great news.

Post Reply

Return to “Electrical”