Chassis DC Fuse Panel Question

Post here for living area electrical.
Author
Message
Offline
Moderator
Moderator
Posts: 1249
Joined: Sat Jan 26, 2013 2:32 am
Travco Model:
Location: Kerrville, Texas

Re: Chassis DC Fuse Panel Question

Unread post by 77Travco » Mon Mar 16, 2015 10:02 am

I wasn't around all weekend and am catching up. Your description of laying under the dash and shouting obscenities while becoming a better electrician had me laughing. Glad you got it figured out.

Offline
Senior Contributor
Senior Contributor
Posts: 239
Joined: Mon Jul 01, 2013 2:30 pm
Travco Model: 1976 270

Re: Chassis DC Fuse Panel Question

Unread post by RobC » Tue Mar 17, 2015 12:45 pm

So I have DC power to the panel and to each lug. I have some line loss though. \n\nMy battery was at about 12.1 volts at the batt ( I know it needs a charge) but I was only getting around 10.2 at the lugs in fuse box.\n\nI know there is line loss but that seems like a lot.\n\nMy fuse panel was corroded pretty badly and it looked like the Ignition accessory fuse shorted and melted the housing. It still works and I am hoping not to have to replace it ($90 on Ebay if I can't find one salvage) but I will if I have to.\n\nAny help on my line loss issue is greatly appreciated.\n\nRob

Offline
Moderator
Moderator
Posts: 1249
Joined: Sat Jan 26, 2013 2:32 am
Travco Model:
Location: Kerrville, Texas

Re: Chassis DC Fuse Panel Question

Unread post by 77Travco » Tue Mar 17, 2015 4:00 pm

Old, dirty, corroded connections don't help. What kind of shape is the actual wire in? Cut into them and check for internal corrosion like a battery cable would have.\nAlso - disconnect the circuit at the source and check for any parasitic voltage draw with a volt meter in series. (between the source and load)

Offline
Senior Contributor
Senior Contributor
Posts: 107
Joined: Sun Mar 01, 2015 5:38 pm
Travco Model: None - Dodge chassis info

Re: Chassis DC Fuse Panel Question

Unread post by Dave78Chieftain » Tue Mar 17, 2015 5:30 pm

If both BATT ACC fuse and IGN ACC fuse (Key ON) are both low at 10.6VDC, then problem is either main battery cables or connections at starter relay (fusible link)\n\nIf BATT ACC fuse is +/- .2 of Battery voltage and IGN ACC fuse is low, the problem is in either ignition switch or cabling to ignition switch\n\nif IGN ACC fuse is +/- .2 of Battery voltage (key ON) and BATT ACC fuse is low, problem is between starter relay and fuse box\n\nif HORN B/UP fuse is low and other fues are OK, problem is IGN 1 circuit (main run circuit) from ignition switch\n\nif INST LPS fuse is low and all other fuses are +/- .2 of Battery voltage, then problem is headlight switch.\n\nDave

Offline
Senior Contributor
Senior Contributor
Posts: 239
Joined: Mon Jul 01, 2013 2:30 pm
Travco Model: 1976 270

Re: Chassis DC Fuse Panel Question

Unread post by RobC » Wed Mar 18, 2015 2:15 pm

Thanks Dave: that helps a lot.\n\nGot the battery charged up and getting full voltage on the Batt Acc side of the fuse panel but the whole lug side (all fuse connections on the ACC fuse side is down by 2 volts. The wire to that whole side (ACC, radio, etc) when pulled off the fuse lug is down so I have to chase that into the steering column. From your description sounds like something in the ignition switch. it acted up a couple times as in nothing when you turned the key then all of a sudden it started with the next turn of the key.\n\npretty sure it is in ignition switch.\n\nThis site is the best.\n\nRob

Offline
Senior Contributor
Senior Contributor
Posts: 107
Joined: Sun Mar 01, 2015 5:38 pm
Travco Model: None - Dodge chassis info

Re: Chassis DC Fuse Panel Question

Unread post by Dave78Chieftain » Wed Mar 18, 2015 6:56 pm

Ignition Switch plug at base of steering wheel\nThe 12ga light blue (2nd pin next to 18ga orange wire [one end of plug; circuit 18 for start]) is the wire [circuit J2] to the IGN ACC fuse from the ignition switch.\n\nThe 12ga Black wire (pin 5 from orange wire end; circuit A20C) is the B+ to the switch. Before tearing into the steering column, make sure you have the correct voltage on the Black wire. If not correct there then best bet is bad fusible link at starter relay (driver side frame rail).\n\nDave

Offline
Senior Contributor
Senior Contributor
Posts: 239
Joined: Mon Jul 01, 2013 2:30 pm
Travco Model: 1976 270

Re: Chassis DC Fuse Panel Question

Unread post by RobC » Wed Mar 18, 2015 7:41 pm

Checking it out tonight Dave.\n\nThe whole right side fuse panel lug is low voltage (all fuses not just IGN acc) I see what I can find and poke around the starter relay too.\n\nRobC

Offline
Senior Contributor
Senior Contributor
Posts: 107
Joined: Sun Mar 01, 2015 5:38 pm
Travco Model: None - Dodge chassis info

Re: Chassis DC Fuse Panel Question

Unread post by Dave78Chieftain » Thu Mar 19, 2015 4:58 am

All those are supplied from the same source (ignition switch). Please note that except for the TSIG/BRK WARN fuse, all are supplied by the ACC pin on ignition switch. The TSIG/BRK WARN fuse is from the ignition 1 pin,\n\nDave

Offline
Senior Contributor
Senior Contributor
Posts: 239
Joined: Mon Jul 01, 2013 2:30 pm
Travco Model: 1976 270

Re: Chassis DC Fuse Panel Question

Unread post by RobC » Thu Mar 19, 2015 12:48 pm

Found another volt under the dash by replacing this ignition switch to fuse panel connector [per Dave's instructions. Acesneights: I recall you telling me to look for this last year under another post. you were right. The connector was melted all to hell as you can see. \n\nI charged the battery and left the ignition switch on by accident and this little connector was hot to the touch. Voltage still passing through it but lots of corrosion and resistance.\n\nStill only getting 11.8 v or so on the ignition (blue wire side) as compared to 12.6 on the black wire side. Starter relay seems OK I will check the voltage at the ignition lug on the starter relay to make sure- THEN tear in to the steering column to look at the ignition switch connections.\n\nThanks for bearing with me on my noob electrical adventures. \n\nOther good news: I was chasing grounds and removed my stock IV bag windshield wiper fluid container. It still holds water! \n\n
IMG_0953.JPG
You do not have the required permissions to view the files attached to this post.

Offline
Contributing Member
Contributing Member
Posts: 50
Joined: Fri Mar 02, 2018 8:40 pm
Travco Model: 67 270

Re: Chassis DC Fuse Panel Question

Unread post by ryemadd » Thu May 24, 2018 1:18 am

I got a 66. Tried to hook up a constant 12v source and my cabin lights all wenf out. But only fuse blown in dc panel is tge 2nd. Any help

Post Reply

Return to “Electrical”